Eclispe 中不支持 for-each 的错误信息的修正

fortruth posted @ 2008年4月07日 19:16 in develop with tags Eclipse , 2151 阅读

在 jre 版本 为1.6.0 下编译java代码, 在for each 行循环意外报错, 错误信息是“语法错误,仅当源级别为 5.0 时“for each”语句才可用”

解决方法:

在eclipse下,选窗口(Windows)->首选项(Preferences)->Java(Java)->编译器(Complier),将里面的编译器一致性级别(Compiler compilance level) 设置为6.0 (如果你用5.0也出现这种现象,就选5.0)。然后应用设置。

参考来源:
http://hi.baidu.com/06whuiss/blog/item/7154a5c4441347ad8226accd.html


登录 *


loading captcha image...
(输入验证码)
or Ctrl+Enter